EnergyMech

Forum | Features | Download | Addons | Help | #emech | Links | About | Contact

Versions | News Archive | Installing | Linking | Configuration | Commands | FAQ


The time is now Saturday, November 18th, 2017, 10:23am

Create account ]   User/Pass   


Forum Index :: Bug Reports :: Unable to add spy channel with filename as target :: Reply to this topic

Author
 
Xaero
Posted :: 1:25pm, Tue, Apr 13, 2010     Subject :: Unable to add spy channel with filename as target

(anonymous)
 
    Version: 3.0.99p3 (July 24th, 2009)
Features: alias, bounce, chanban, dyn, md5, net, newbie, rawdns, seen, session, telnet

Have included this in config file:
set spy 1
spy #testing > testing.log

but it doesn't log to the file and doesn't show up in the spy list so I tried to add it manually with "-spy #testing > testing.log" via DCC chat. That too doesn't work. But "-spy message #testing" works - pm's sent to the bot go to the channel but "-spy message > pm.log" doesn't work. Which I think is a bug coz it works in the 3.0.1 version. I can't find any other documentation on this. Also "-usage spy" gives an output:
Usage: SPY [STATUS|MESSAGE|RAWIRC|[guid":"|botnick":"] [channel|">" filename]
(the braces don't match, 3 open 2 close)

 
Xaero
Posted :: 7:09pm, Tue, Apr 13, 2010

(anonymous)
 
    Sorry this is not a bug - the way you mentioned it in this thread [http://www.energymech.net/forum/read.php?fid=ab&tid=8126621] with spaces around the ">" worked on the old one which is a windows build. I am running the new one on linux, maybe that has something to do with it?
I finally got it works after days of fiddling with it and searching but it's very hard to come by any docs but I got it working anyway with "-spy #testchan>testchan.log" which shouldn't contain spaces. xD

 
Xaero
Posted :: 7:26pm, Tue, Apr 13, 2010

(anonymous)
 
    k, i spoke too soon :(
It added the whole "#testchan>testchan.log" to source and me as destination. Everything in the spy command works except with a logging to file :/.
Thx

 
Xaero
Posted :: 7:11am, Sun, Apr 18, 2010

(anonymous)
 
    Ok, now there's another problem: if I include a msg line in mech.conf then the settings after the mech don't take effect. It's as if they were never there. Is there some kinda order in which the mech.conf should be written? I only have one bot in the file should it matter? BTW, the same mech.conf was working for the cygmech (energymech for windows 3.0.1). But it doesn't work for 3.0.99p3.

Still haven't been able to figure out the logging to file issue. Pls help. Thanks.

 

Copyright © 2000-2005 Proton,  All rights reserved. Last edited August 16th, 2005.
HTML 4.01 CSS