EnergyMech

Forum | Features | Download | Addons | Help | #emech | Links | About | Contact

Versions | News Archive | Installing | Linking | Configuration | Commands | FAQ


The time is now Saturday, November 18th, 2017, 1:47pm

Create account ]   User/Pass   


Forum Index :: EnergyMech 3.x Development :: EnergyMech V2.99.79 dcc recieve? :: Reply to this topic

Author
 
SyKo2K
Posted :: 5:37pm, Wed, Dec 8, 2004     Subject :: EnergyMech V2.99.79 dcc recieve?

(anonymous)
 
    ive got a ported cygwin version,running great
except i cant send a file TO the bot,which is what im after.

i can send a file FROM it no problems.is there some sort of extra permissions
i need to set? the documentation doesnt list a lot of the newer '3 beta' commands
you have implemented,any help would be appreciated. and thanks again for a nice
bot :)

 
proton
Posted :: 6:42pm, Wed, Dec 8, 2004


Posts: 165
 
    You need to set the DCCFILES setting.
This setting is a string with space separated masks.
For instance, "*.exe *.com *.pif *.bat" would accept all the Windows
virii but reject everything else. Just set it to "*" if you dont have
any security concerns.
/pro

 
SyKo2K
Posted :: 7:22pm, Wed, Dec 8, 2004

(anonymous)
 
    well ive tried what you suggested,but its still not getting anywhere.

here is the debug output for when i try to send a file to the bot,along with
the set command settings.

(out) {5} [05:47] [DCC] :SyKo2K[100]: Requested DCC SEND [syk.nfo 3707039355 120
39 166]
(ctcp_dcc) rest: `syk.nfo 3707039355 12039 166'

the set command output=

[4:50am] < SyK-DoWN > Global settings
[4:50am] < SyK-DoWN > aaway=0 altnick=(unset) -autolink banmodes=6 bncport=0 +cc
[4:50am] < SyK-DoWN > cmdchar=`.' +ctcp ctimeout=60 dccanon=4 dccuser=4
[4:50am] < SyK-DoWN > dccfiles=""*.nfo" ident="sykhobo" ircname="IRC"
[4:50am] < SyK-DoWN > isondelay=30 linkport=0 linkpass=(unset) +netusers -noidle
[4:50am] < SyK-DoWN > notifyfile=(unset) -onotice opmodes=6 qfile=(unset) qdelay=30
[4:50am] < SyK-DoWN > qchar=`*' -rf -rv -spy umodes="+w" uphost=""192.168.0.1""
[4:50am] < SyK-DoWN > upport=9969 upnick=(unset) userfile="mech.users"
[4:50am] < SyK-DoWN > virtual=(unset) wingate=(unset) wingport=0 webport=0

thanks for the quick response man :)

 
SyKo2K
Posted :: 7:32pm, Wed, Dec 8, 2004

(anonymous)
 
    also note that i am trying this on both versions,
cygwin and the standard emech,and the output is the same either way.
ive created a public dir etc,as i had to do that for it to send files.
also made a download/s dir in case it needed that too...nada...

 
SyKo2K
Posted :: 8:27pm, Wed, Dec 8, 2004

(anonymous)
 
    could this perhaps be because of the abscence of dcc.c during compile?

i noticed that in your install instructions,gcc points to dcc.c,but this file
isnt present in the 2.99.79.tar.gz file?

ive just downed 2.9.3 from eggheads ftp as it contains the dcc,so we'll see
what happens with this version.

 
SyKo2K
Posted :: 9:44pm, Wed, Dec 8, 2004

(anonymous)
 
    looking @ the code of ctcp.c and h.h ,it seems as though you
have only implemented dcc send support? only other command reference is parse_dcc
-
#ifdef DCC_FILE
LS int dcc_sendfile(char *, char *) __page(CMD1_SEG);
LS void do_send(COMMAND_ARGS) __page(CMD1_SEG);
#endif / * DCC_FILE * /
-

or am i not looking in the right place?

sorry for being annoying,i've been after a bot with this kind of
support for a while,seeing it so close makes me anxious :)

 
SyKo2K
Posted :: 12:55am, Thu, Dec 9, 2004

(anonymous)
 
    ok,appologies regarding my questioning the code,as i see the error of my ways....

im on a LAN,and have 1 nix box ICS'd by XP.(laugh! go on... :P)

now,its grabbing eth0 and using it as the transfer ip,so hence the server/provider
will refuse to route this traffic.

so it needs an optional dcc_ip function,so that you can specifically set an IP
to use in dcc transfers.

same reason people behind routers have problems with dcc transfers.

is there any quick workarounds for this other than a code re-write(shudder)

 
proton
Posted :: 2:35am, Thu, Dec 9, 2004


Posts: 165
 
    You DCCFILES setting includes a " (quote). So unless your file is renamed
"blabla.nfo, it wont work. Try setting it to *.nfo, without the quotes.
I used the quotes in my example because thats how Im used to it.
/pro


 
SyKo2K
Posted :: 3:24am, Thu, Dec 9, 2004

(anonymous)
 
    yeah i noted that after i posted and re-set it,still the same
problem.seems like its not opening a listening connection.ive tried it
on 3 boxes so far(1 gateway,1 lan machine to the same gateway & a seperate windows box.
i know that my dcc send and recieve are fine as ive got
a few ppls helping me test and iron out kinks.i know you stated in the other
topic 2.99.77 regarding the receive implementation is buggy,im confirming it now tho.

also,looking at the code,it only allows certain functions while in DEBUG mode?
or does that mean to compile with debug?(ive compiled with debug anyways,was
running in debug mode earlier to pin-point wtf was going on)

i'll try and see what more i can work out,maybe implement a fix,cheers for your input

im no c wiz,but i'll try

on the plus side,its running very stable,havent had any problems in that area.


 
proton
Posted :: 4:10am, Thu, Dec 9, 2004


Posts: 165
 
    The directory "public/incoming/" must exist and be writable to the mech.
The DCCFILES setting must match the filename of the file sent.
The DCCANON + DCCUSER settings must have at least 1 unused slot for DCC
transfers free.
It does not use local IP in any way, it simply tries to connect out to
the IP/port stated in the DCC SEND command from the side sending the file.
/pro


 
SyKo2K
Posted :: 8:12am, Thu, Dec 9, 2004

(anonymous)
 
    thats done the trick,works beautifully now.

i cant see it documented anywhere,but folks will see this thread and shall be enlightened.

thanks again.

:happy: SyK :happy:

:D :D :D

 
proton
Posted :: 8:49am, Thu, Dec 9, 2004


Posts: 165
 
    It will be documented in time, but time is something I dont have an
infinite amount of so stuff only happens bit by bit, not as people
expect, all at once.
/pro

 
SyKo2K
Posted :: 5:15pm, Thu, Dec 9, 2004

(anonymous)
 
    well if you need some help documenting stuff give me a holler.im sure i could
dedicate a hour or two a day to type up some docs.for a one man project youve done
awesome things :)

 

Copyright © 2000-2005 Proton,  All rights reserved. Last edited August 16th, 2005.
HTML 4.01 CSS