EnergyMech

Forum | Features | Download | Addons | Help | #emech | Links | About | Contact

Versions | News Archive | Installing | Linking | Configuration | Commands | FAQ


The time is now Monday, November 20th, 2017, 1:19pm

Create account ]   User/Pass   


Forum Index :: Generic Discussion :: I'm sure that this has already been answered :: Reply to this topic

Author
 
warchild
Posted :: 6:10pm, Tue, Oct 18, 2005     Subject :: I'm sure that this has already been answered


Posts: 4
 
    But I have been messing with this problem for days now and can't seem to find an answer
I have the bot joined into the channel I want
but everytime I try to verify with my bot, it verifies but says my password is incorrect

this is my userfile.mech

user warchild
mask *!*warchild@*.dhcp.rsbg.or.charter.com
chan *
opt u100
access #(channel name)warchild_ *!*warchild@*.dhcp.rsbg.or.charter.com
add warchild_ *|(room name) *!*warchild@*.dhcp.rsbg.or.charter.com 100 1 4 password
setpass warchild_ password
op (channel name) warchild_ *!*warchild@*.dhcp.rsbg.or.charter.com

Any suggestions???

 
agonizer
Posted :: 5:41pm, Thu, Oct 20, 2005


Posts: 54
 
    > Any suggestions???

Just questions: What does the "access #...", "add ..." and "op ..." mean in the
userfile?

also i would remove the password from the userfile, start the bot, then set the
(new) password with PASSWD...

 
warchild
Posted :: 3:27am, Sun, Oct 23, 2005     Subject :: Thanks so much agonizer


Posts: 4
 
    It's figures I would do something to over-complicate everything

I got everything working and verified thanks to agonizer. I have one other
noob question and I'm sure it's rather stupid, but I thought that the bot
was supposed to op me once I verified, yet it's not.

I'm sure it's just something that I'm missing in some configuration file

Any suggestions anyone??



 
agonizer
Posted :: 2:54pm, Sun, Oct 23, 2005


Posts: 54
 
    Ensure that

1) your user has the auto-op (+AO) flag set, and
2) auto opping is enabled for the channel (see REPORT).



 
warchild
Posted :: 4:43pm, Sun, Oct 23, 2005     Subject :: Ok, so if I got your instructions correct (which I probably didn't, because it's still not working)


Posts: 4
 
    in my userfile, I should have

user warchild_ +AO (right?)
mask blah blah
chan *
opt u100

and then in mech.conf

I should have SET AOP 1 or 0 right??

I know I'm such a noob it's pathetic

 
agonizer
Posted :: 6:36pm, Mon, Oct 24, 2005


Posts: 54
 
    >user warchild_ +AO (right?)
No.

/MSG <botnick> .USER warchild_ +AO (perhaps you have to add the channel name here
somewhere, i dont know)

The help for the USER command would give you some help i think...

>and then in mech.conf
>I should have SET AOP 1 or 0 right??

Dunno too. I would use "/MSG <botnick> .SET #channel AOP 1"


 
warchild
Posted :: 9:36pm, Mon, Oct 24, 2005     Subject :: Once again you did it Agonizer


Posts: 4
 
    I'm all up and running now. Thank you very much Agonizer, you are THE BOMB!!!!!

 

Copyright © 2000-2005 Proton,  All rights reserved. Last edited August 16th, 2005.
HTML 4.01 CSS