EnergyMech

Forum | Features | Download | Addons | Help | #emech | Links | About | Contact

Versions | News Archive | Installing | Linking | Configuration | Commands | FAQ


The time is now Tuesday, September 19th, 2017, 8:38pm

Create account ]   User/Pass   


Forum Index :: Generic Discussion :: don't want to connect :: Reply to this topic

Author
 
sartek
Posted :: 3:29am, Sun, Nov 20, 2005     Subject :: don't want to connect

(anonymous)
 
    Hi i installed emech 3.0 and that don't want to connect to the irc server
i have firewall turned off?
some tipp?

 
dimi
Posted :: 12:54pm, Tue, Nov 22, 2005


Posts: 28
 
    Look for the config manual on www.energymech.net

 
kitten
Posted :: 4:44am, Mon, Sep 18, 2006


Posts: 2
 
    Hello forum.

I also have the same kind of problem and I'm unable to find good
pointers right now. As conf doc suggested, I created mech.conf from
scratch (keeping eye on sample.conf though).
So I have this line in mech.conf (and mech.session):
server irc.cc.tut.fi 6667

If I say `netstat -n -p |grep 666`, I see only my irssi client and
eggdrop bot (which I'm desperately trying to get rid of) connecting
to such port.

I also tried with other servers such as undernet server in sample.conf
by adding them in mech.session.

I'm thinking the problem might be in DNS resolving. I've added
dnsserver (from my /etc/resolv.conf) and even dnsroot lines in the
mech.conf and always removed mech.session afterwards. Debug feed also
says my that dnsroot option was interpreted correctly (according to the
spam ;)

But even after this I get debug such as:
(rawdns) questions 127.0.0.1: irc.cc.tut.fi
(rawdns) questions 127.0.0.1: uptime.energymech.net
(select_rawdns) removing uptime.energymech.net qid 28766
(rawdns) questions 127.0.0.1: uptime.energymech.net
(select_rawdns) removing uptime.energymech.net qid 18999
(select_rawdns) removing irc.cc.tut.fi qid 16215

Which should not be 127.0.0.1?

Any pointers or advice?


 
kitten
Posted :: 10:56am, Mon, Sep 18, 2006


Posts: 2
 
    Just "walking by" to tell that I "fixed" it by recompiling without dynamic
DNS support. I don't know if I'm missing some very fancy feature, but at
least it connects now.

Still don't mind if someone wants to shed some light about this issue :)

 

Copyright © 2000-2005 Proton,  All rights reserved. Last edited August 16th, 2005.
HTML 4.01 CSS