EnergyMech

Forum | Features | Download | Addons | Help | #emech | Links | About | Contact

Versions | News Archive | Installing | Linking | Configuration | Commands | FAQ


The time is now Monday, November 20th, 2017, 3:31pm

Create account ]   User/Pass   


Forum Index :: Generic Discussion :: Trivia in 3.0.1 :: Reply to this topic

Author
 
drym
Posted :: 2:02am, Mon, Jan 30, 2006     Subject :: Trivia in 3.0.1


Posts: 3
 
    I have trivia support enabled, downloaded the trivia file, etc...but I can't figure out how to get it working.
I've read everything I could find about it, but to no avail. Any help would be appreciated.

Thanks

 
Krillian
Posted :: 11:03pm, Sun, Feb 5, 2006     Subject :: Same problem here...

(anonymous)
 
    after searching for answer like 4 hours, I have to surrender and ask for help.

Can anyone tell me if there's some trick to do to get this trivia thingy working ?
Someone mentioned there should be README.FEATURES file in the distribution package,
but there isn't...

 
drym
Posted :: 6:19am, Mon, Feb 6, 2006


Posts: 3
 
    Kinda glad I'm not the only one having trouble. the readme.features file doesn't exist, nor does mkindex in 3.0.1.

 
agonizer
Posted :: 9:28pm, Thu, Feb 9, 2006     Subject :: Trivia:


Posts: 54
 
    1) copy the questions file into the bots dir (i.e. as 'questions').

2) you need do build the 'mkindex' utility (trivia/mkindex.c):
$ gcc -O2 trivia/mkindex.c -o mkindex

This will create the mkindex binary in the bots dir.

3) Build the index over the question file (the generated file is
named '<file>.index', i.e. questions.index):
$ ./mkindex questions
49124 entries indexed

4) Start the bot and tell the location of the question file:
SET QFILE ./questions

5) TRIVIA START
Trivia starting! Get ready...
In which county does the River Mersey rise


There you go.




 
drym
Posted :: 6:45pm, Fri, Feb 10, 2006


Posts: 3
 
    Thank you.

 
eaonflux
Posted :: 7:20am, Thu, Aug 30, 2007     Subject :: trivia with 3.0.2

(anonymous)
 
    Hi,

i tried your solution.

$ ./mkindex questions
49124 entries indexed

4) Start the bot and tell the location of the question file:
SET QFILE ./questions

but i still get an bad questions file error.
i use the 3.0.2

can any one explain how i get this to work?

grtz,

eaonflux



 
anotherone
Posted :: 6:25pm, Wed, Jan 26, 2011     Subject :: this works

(anonymous)
 
    after doing all the above.....
just type .set qfile questions
leave off the ./ of ./questions, it'll figure out which dir to look in



 
anotherone
Posted :: 6:27pm, Wed, Jan 26, 2011     Subject :: this works

(anonymous)
 
    after doing all the above.....
just type .set qfile questions
leave off the ./ of ./questions, it'll figure out which dir to look in



 

Copyright © 2000-2005 Proton,  All rights reserved. Last edited August 16th, 2005.
HTML 4.01 CSS