EnergyMech

Forum | Features | Download | Addons | Help | #emech | Links | About | Contact

Versions | News Archive | Installing | Linking | Configuration | Commands | FAQ


The time is now Sunday, September 24th, 2017, 10:33am

Create account ]   User/Pass   


Forum Index :: Generic Discussion :: Enable TCL Scripting :: Reply to this topic

Author
 
ezinex
Posted :: 1:27am, Sun, Aug 21, 2005     Subject :: Enable TCL Scripting


Posts: 5
 
    Is there a way of activating TCL scriptin (manualy) in th e3. I read i have to enable some stuff on config.h, but it changes when i enable it. Could this be a small bug, or has to work like that for some kind of protection.

 
kroseneg
Posted :: 7:07pm, Mon, Jun 12, 2006


Posts: 12
 
    You need the tcl headers on the machine where you're compiling your emech. Install them first, then do a ./configure, perhaps you'll need to specify the location of your tcl-headers to configure (see ./configure --help for options)

 
ezinex
Posted :: 6:48pm, Sat, Jul 15, 2006     Subject :: Thanks!


Posts: 5
 
    It Worked

 
thedarthjysky
Posted :: 5:16pm, Sat, Dec 23, 2006


Posts: 1
 
    I'm trying to compile emech 3.0.2 on openSUSE 10.2 and I have tcl and tcl-devel packages installed, still configure script says that I don't have tcl headers installed even though i do.

 
stali0n
Posted :: 5:41pm, Sun, Sep 23, 2007     Subject :: ./configure --with-tcl=yes ... bug issue


Posts: 1
 
    Hi, I tried to compile the energymech with tcl support but it Won't and I don't
know Why because I already have eggd**p install with tcl and it work Ok ... but
I try command to acitve tcl but It won't work

@oxiz:~/emech3$ ./configure --with-tcl=yes --enable-tcl=yes

checking for tcl ... no

after the prompt for add or remove feature it says:

Tcl scripting support? ..................... [y/N] no (unsupported)

So i tried Other way to activate like by Pointing directly to the tcllib with:

@oxiz:~/emech3$ ./configure --enable-tcl=yes --with-tcl=/usr/lib/libtcl8.3
unknown argument for tcl: /usr/lib/libtcl8.3
Usage: configure [options]
use "./configure --help" for help

but as you can see it won't works too... So do you know any trick to modify the
"./configure" script so that i can specify where is my lib directly in the script??

thanks in advance.


 

Copyright © 2000-2005 Proton,  All rights reserved. Last edited August 16th, 2005.
HTML 4.01 CSS